Linux Agent Packages - Key Expired

From Thursday, 26th October 2017 you may encounter an error message similar to the following: 

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://archive.serverdensity.com/ubuntu all InRelease: The following signatures were invalid: KEYEXPIRED 1509014164 KEYEXPIRED 1509014164 KEYEXPIRED 1509014164

 This is due to the key that we use to sign our agent packages with expiring on Thursday, 26th October 2017. If you installed the agent before Thursday, 26th October 2017 it is likely that you will encounter this issue. 

How to Fix

To fix this issue you need to update the key on your server to the new key that we use to sign our packages. You can do this with the following: 

Debian/Ubuntu

curl -Ls https://archive.serverdensity.com/sd-packaging-public.key | sudo apt-key add -

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

  • Avatar
    Charles Alva

    Whoa, that was fast. Thanks! :)

Monday  —  Friday.

10am  —  6pm UK.

Dedicated Support.